Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony DCR-PC1000E - lens cover not working...easy fix?

Discussion in 'Camcorders & Video Editing' started by mattheww_nz, Jul 27, 2008.

  1. mattheww_nz

    mattheww_nz Member

    Joined:
    Apr 22, 2007
    Messages:
    12
    Trophy Points:
    1
    Ratings:
    +0
    Hi - I have a Sony DCR-PC1000E which I have had a couple of years but use relatively infrequently. I pulled it out today and the lens cover would not open. The error message on the screen suggests turning on and off but to no avail.

    I'm guessing it needs to go in for repair but was keen to hear if anyone else has had a similar experience and if so what the cost etc. was? I am based in west London W9 so any advice on where to go would be much appreciated as well.

    Many thanks!
    Matthew :)
  2. Sharky71

    Sharky71 Member

    Joined:
    Nov 5, 2008
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0
    Mathew

    Ours did the same about a month ago. After a quick shake(of the cam!) it fixed it.

    Now it has happened again. I have tried the 'shake' method again, but to no avail. What happened to yours?

    Any quick fix?

    Thanks
    Steve
  3. mattheww_nz

    mattheww_nz Member

    Joined:
    Apr 22, 2007
    Messages:
    12
    Trophy Points:
    1
    Ratings:
    +0
    Hi Steve - a quick fix but the more expensive one - I ended up sending it to Sony who fixed the motor. Can't remember how much exactly but about £150....

    Cheers,
    Matthew

Share This Page