Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Safari Randomly Closing 4S Problem or iOS5 Problem? Or my Problem?

Discussion in 'iPhone' started by Cha1ky, Nov 1, 2011.

  1. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    I did a search and didnt seem to get any results.

    I was just wondering if anyone else is having Safari randomly close whilst browsing the net?

    I've just got my 4S 64GB iPhone and just want to see if its my problem, a known iPhone 4S problem or perhaps an iOS 5 problem.

    Anyone else been having this happen? If so which of the above is it for you.
  2. Madkatz

    Madkatz Member

    Joined:
    Oct 10, 2011
    Messages:
    22
    Trophy Points:
    1
    Ratings:
    +0
    Yes this has been an issue for a while. It has been happening very frequently on the iPad. On the previous iOS and on ios5. I had hoped that the upgrade to ios5 would solve it, but it hasn't. I now have an 4s 64gb and it is happening on that too. Did a reset and it behaved for a while but has started doing again later the same day.
  3. dllord

    dllord Member

    Joined:
    Sep 8, 2005
    Messages:
    1,053
    Trophy Points:
    48
    Ratings:
    +31
    Its been happening to me since i got my 4S! Very annoying!
  4. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    That's good that its not just me then. Can be very frustrating when typing a reply for here then it goes back to the home screen and when i go back it reloads the page. It literally did it 4 times in a row today and i got potty mouth in a pub. :blush:

    I'm not 100% sure if it happens only when i'm checking AVF as from memory that seems to be the only site that it closes on. But i'll certainly be keeping my eye out now.

    Anyone any ideas of any possible fixes in the works.


    Also i get random AVF pages showing up with the reader option. I wonder if that has anything to do with it???? Bug somewhere perhaps.
  5. ikon66

    ikon66 Member

    Joined:
    Mar 22, 2005
    Messages:
    383
    Trophy Points:
    21
    Ratings:
    +6
    and me :mad: even worse when your half way through typing a reply in a forum :rolleyes:
  6. muffins

    muffins Active Member

    Joined:
    Feb 1, 2008
    Messages:
    2,865
    Trophy Points:
    106
    Ratings:
    +265
    Started happening to me on my iPad 2 since iOS 5 and on my iPhone 4S only on avforums.
  7. masebetha

    masebetha Member

    Joined:
    Oct 26, 2011
    Messages:
    30
    Trophy Points:
    6
    Ratings:
    +0
    Happened on my iPhone 3GS too, no doubt it's a bug on iOS 5. Should be fixed by the next update.
  8. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    I hope so as its highly annoying!!
  9. hybridtheory

    hybridtheory Active Member

    Joined:
    Mar 31, 2009
    Messages:
    6,238
    Trophy Points:
    106
    Ratings:
    +387
    Hi

    I havent noticed it happening on my iPhone 4S but I did happen over the weekend while using my g/f's iPad 2 with iOS 5. Only seemed to happen while trying to post on here. Very annoying when ur half way through a post :(/

    Baz
  10. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    Yeah so far I have noticed it to just be whilst being on here. Especially when going to post.
  11. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    Still no change after the latest update.

    Tried other sites but AVF seems to be the only one that it crashes on. :thumbsdow
  12. muffins

    muffins Active Member

    Joined:
    Feb 1, 2008
    Messages:
    2,865
    Trophy Points:
    106
    Ratings:
    +265
    Same here. I wonder if it's an avf problem?
  13. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    There has to be something on here that's causing it. Adverts perhaps.
  14. Doovd

    Doovd Member

    Joined:
    Sep 7, 2008
    Messages:
    276
    Trophy Points:
    21
    Ratings:
    +18
    has anyone tried settings-safari-clear history and clear cookies close app from background then restart phone and use private browsing for AVF?
  15. gkpm

    gkpm Active Member

    Joined:
    Mar 3, 2005
    Messages:
    2,528
    Trophy Points:
    106
    Ratings:
    +358
    It's an iOS5 bug triggered by the layout of AVForums (especially the reply box). I've only tracked it down to when iOS goes to render the page it triggers an out of memory error.

    Haven't looked much more since AVForums includes too many layers of Javascript. It could be fixed from AVForums's end but can't see anyone looking at this site's code and remaining sane, best bet is to wait for Apple to fix (they already have a report)

    There's already a discussion here: http://www.avforums.com/forums/iphone-apps/1528267-avforums-app-keeps-crashing-ios-5-a.html

    Why would anyone do that? Don't think it'll make any difference because the error is in the rendering.
    But feel free to try it and report back.
    Last edited: Nov 12, 2011
  16. Doovd

    Doovd Member

    Joined:
    Sep 7, 2008
    Messages:
    276
    Trophy Points:
    21
    Ratings:
    +18
    I just replied using Safari, I was hoping it would help somehow sorry about that. ;)
  17. gkpm

    gkpm Active Member

    Joined:
    Mar 3, 2005
    Messages:
    2,528
    Trophy Points:
    106
    Ratings:
    +358
    Great that you're trying it, but it tends to need a larger reply to crash, 3 or 4 lines (though it crashes even on single liners sometimes)

    Just gave your idea a go myself and it crashed while typing this in, so no luck I'm afraid.
  18. Doovd

    Doovd Member

    Joined:
    Sep 7, 2008
    Messages:
    276
    Trophy Points:
    21
    Ratings:
    +18
    How about turn off bookmarks in iCloud and Turn off Safari in location services? once again I'm typing this out on the phone trying to figure out why some people are affected and others not?
  19. Doovd

    Doovd Member

    Joined:
    Sep 7, 2008
    Messages:
    276
    Trophy Points:
    21
    Ratings:
    +18
    I did encounter a safari cannot open page problem but I previewed the post and then submitted and it worked.
  20. gkpm

    gkpm Active Member

    Joined:
    Mar 3, 2005
    Messages:
    2,528
    Trophy Points:
    106
    Ratings:
    +358
    Nope, still crashes.

    Think everyone is affected by this problem but it only happens here and in a couple of other forums (which run the same forum software) It reminds me of a previous bug which crashed on Tesco direct's website (another Javascript heavy site) but was eventually sorted out.

    The app does sort it out, since the last update I haven't had a crash there.
    Last edited: Nov 12, 2011
  21. Cha1ky

    Cha1ky Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    29,319
    Trophy Points:
    166
    Ratings:
    +10,884
    Fingers crossed it gets sorted sooner rather than later for the sake of my sanity!!!!

    It always does it to me when i'm typing the last sentence of a reply!!! :mad::mad:

    Got a tip on the PS3 forums. If doing big replies, right them out in notes first!!!


    Is the AVForums app sorted now? If so i'll start using it.
    Last edited: Nov 13, 2011
  22. wassa

    wassa New Member

    Joined:
    Nov 5, 2005
    Messages:
    16,422
    Trophy Points:
    0
    Ratings:
    +669
    Any resolve for this yet guys as my 4s is 2 days old and keeps doing this:(
  23. leebroath

    leebroath Active Member

    Joined:
    Aug 7, 2005
    Messages:
    3,667
    Trophy Points:
    106
    Ratings:
    +452
    I can confirm my 4S crashes only apply to Av forums while typing a reply

    And also when typing a big reply, it's like it starts struggling :(
  24. leebroath

    leebroath Active Member

    Joined:
    Aug 7, 2005
    Messages:
    3,667
    Trophy Points:
    106
    Ratings:
    +452
    Can't remember that one ;) lol


    I just went and tried to delete most of this quote and it crashed twice, so it's not just when typing a reply, try deleting lots of text with finger held on button
  25. wassa

    wassa New Member

    Joined:
    Nov 5, 2005
    Messages:
    16,422
    Trophy Points:
    0
    Ratings:
    +669
    Can AVF fix this ?
  26. wassa

    wassa New Member

    Joined:
    Nov 5, 2005
    Messages:
    16,422
    Trophy Points:
    0
    Ratings:
    +669
    Right I am now typing this with the forum app and it's working fine :) this is what apple just recommend to me :) but must admit preferred using safari just need to get used to this I suppose
  27. wassa

    wassa New Member

    Joined:
    Nov 5, 2005
    Messages:
    16,422
    Trophy Points:
    0
    Ratings:
    +669
    New update came out today apple told me to install it so far so good using it now seems ok :thumbsup:

Share This Page