Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LG 42LV5400, constantly asking for pairing key

Discussion in 'LCD & LED LCD TVs' started by noisycats, Jan 17, 2012.

  1. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Hopefully someone can help or at least has a similar problem.

    About once every 30 minutes to an hour, I have the box pop up on the screen asking for a pairing key with 6 "dots". I can't for the life of me figure out what the TV is trying to pair with?

    It did this even before I had the LG iPhone app, and still does it now that I have the app successfully installed. LG has told me there is no way to turn off this feature and that some device is trying to connect to my TV (or vice versa).

    There is another iPhone in the household but I've tried with both phone powered down and I still get the message. The TV is hardwired to the router (ethernet) and the wifi dongle for the TV is not installed. I do have the Magic Remote. The router is also wirelessly talking to a Roku, Apple TV1, and Apple TV2, and via wired connection to the Tivo. All devices work perfectly. There is a wifi iPad in the house and two iMacs (although we only use the media library from one of them) and all content is fed through the Apple TVs. Nothing is jailbroken. There is no DNLA or Plex or XMBC installed on any of the devices or computers.

    I have tried with every device turned off at some point and I still get the message.

    If any of my devices were not working, it would be a different issue, but everything works as designed. Anyone with any ideas?
  2. iaint

    iaint Member

    Joined:
    Jul 4, 2011
    Messages:
    633
    Trophy Points:
    28
    Ratings:
    +90
    Hi.
    Unplug the ethernet to the router?
    --
    Regards, Iain.
  3. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Thanks. I will give that a try tonight. It will probably 'fix' the problem, only I need my TV connected to the internet.

    I'm still open to other ideas, but I at least have something to try tonight.
  4. iaint

    iaint Member

    Joined:
    Jul 4, 2011
    Messages:
    633
    Trophy Points:
    28
    Ratings:
    +90
    Hi.
    Was thinking just problem isolation. Next step would be to disconnect everything else from the router (and switch the wireless off). Make sure it's not the router causing the problem.
    Then reintroduce a controlled number of things at a time; if all the wired things can be reconnected without causing the problem; it's one of your wireless devices. Maybe a smartphone searching for DLNA players...
    --
    Regards, Iain.
  5. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Thanks. You were on the right track. Unplugging the ethernet stopped the behavior, but it promptly returned upon connecting the TV back to the router.

    I've got it down to either of the ATVs, the Tivo, my iMac, or the router itself. Everything else has been excluded from the network without stopping the behavior.
  6. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    It is most certainly my iMac. the behavior stops completely while my computer is shut down and occurs 5 of 5 restarts.

    Any idea of what start-up process on the Mac could be initiating this behavior from the LG TV? While the message will pop up every 15-30 minutes while both TV and computer are on, the first message will pop up when the computer has been restarted, even before the desktop appears.

    Thanks for the help!
  7. iaint

    iaint Member

    Joined:
    Jul 4, 2011
    Messages:
    633
    Trophy Points:
    28
    Ratings:
    +90
    Hi.
    Sorry; not all that clued up on MacOSX, but would guess there's something media-sharing related running, perhaps have a look at what's enabled in system preferences -> sharing? Note down what's enabled before changing anything... Anything running (look for the glow on icons on the dock) that may be media-sharing-related? Right-click and quit things to test...
    --
    Regards, Iain.
  8. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Thanks again. I think this is where I get stuck. I can force the message to appear by restarting the computer, the first message will pop up between the start-up chime and the appearance of the desktop; suggesting it is a very early, and likely core, process. I don't see anything occurring in Activity Monitor that is unique to a particular application. I have standard items shared (screen, file, and remote login) and I'm not too keen on shutting down core services to eliminate the pop up message.

    I'm afraid, as much as I like the TV, that it will be easier to return it and pick up something else. I'll make a last ditch effort on a Mac centric site, maybe someone there will have an idea. It is a shame that LG doesn't include a setting to turn off this behavior.
  9. iaint

    iaint Member

    Joined:
    Jul 4, 2011
    Messages:
    633
    Trophy Points:
    28
    Ratings:
    +90
    Hi.
    I note you mention it's specifically your iMac, not the other one? Any configuration differences?
    The other possibility that occurs to me is to move the TV to another network; nice cheap "cable router"; connect WAN port to existing network, connect TV to LAN port on new router.
    Firewall on new router prevents macs connecting to TV. TV can still connect out to web streaming stuff like iPlayer and YouTube...
    --
    Regards, Iain.
  10. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Great catch. Yes, it is only my iMac. The difference is my iMac drives the "home sharing" utilized by the other iMac as well as both Apple TVs. Thanks for further narrowing this down...it seems like some process initiating with my iMac acting as a sort of simple media server for the home and the TV is picking up on that. What I'm worried about now is once I find the culprit, I likely won't disable it as everything is working exactly as I want it to. I wish I could just stop the TV from trying to mate with my iMac.

    Can you elaborate on your separation instruction above? I have a guest network set up on my wireless router. I'm wondering if I set my TV to connect wirelessly to my guest network (which is firewalled from my iMac), if that would stop the messaging?
  11. iaint

    iaint Member

    Joined:
    Jul 4, 2011
    Messages:
    633
    Trophy Points:
    28
    Ratings:
    +90
    Hi.
    If you already have the WiFi adaptor for the TV, it's definitely worth a try. Ideally you'd want to block both traffic from the LAN to the guest WiFi as well as traffic from the guest WiFi to the LAN. You may already be doing this; depends upon how exactly your guest WiFi is setup. My suggestion would be essentially similar; the idea to put some sort of firewall inbetween the TV and iMac that disallows connections from the iMac to the TV, but still allows the TV to access online streaming stuff. The simplest solution that occurred to me was the "cable router" (i.e. router with a WAN ethernet port rather than WAN ADSL port), but if your wireless router already has the facility setup...
    --
    Regards, Iain.
  12. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Hey Iain,
    Success of sorts. Creating an intervening firewall stopped the annoying behavior. I'm still curious as to what precise process on the part of the iMac was causing the pop-up, but I should be satisfied that it will occur no more. Thanks for the huge assist!
  13. pmdf

    pmdf Member

    Joined:
    Jan 6, 2006
    Messages:
    19
    Trophy Points:
    3
    Ratings:
    +1
    I've got this exact same issue on my LW650T and have posted about it in another thread. I found one other reference to it on another forum, and that person had Macs on his network - as do I.

    My Tv is connected via Ethernet and there are a few Macs on my network, including an always-on Mac Mini which I use both as a general server and as my HTPC. Restarting any of the Macs causes the Pairing Key to pop up and occasionally bringing an iPhone or iPad (connected on the network) out of sleep will also cause it to pop up. Other times it just seems to pop up of its own accord! The Mac Mini has all sorts of server processes running (OS is Lion Server), but I've not been able to isolate any particular service - for example it seems starting and stopping the DNS server process will consistently cause the key to pop up, but even with that disabled completely and using an external DNS instead I'm still getting the Pairing Key popup seemingly at random and when restarting other Macs on the network. I've been driving myself mad trying to fix this and the only solution I've found is to take the TV off the network, which is not much of a fix when I use the online features a lot. I also use both DLNA and Plex on the LAN.

    I did call LG Support for a chat and they said that hadn't encountered the issue before. They seemed to take it quite seriously and put me on hold while they consulted with a couple of different folk there, but couldn't come to any resolution.

    Any tips on how you configured your firewall, as my attempts to do the same haven't solved the problem... :(
    Last edited: Jan 31, 2012
  14. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    I have a wireless Airport Extreme Base station that pretty much controls the whole house. I had desired an ethernet connection from the TV to the AEB, but that only ensured the message would repeatedly pop up.

    When I set up the AEB, it included the option for a "Guest" wireless network separate from the personal wire network. I guess the theory is that any guest in your home could access the wireless guest network and access the interwebz but not access anything behind your home firewall.

    The TV is connected wirelessly to the guest network and that has prevented communication between my iMac and the TV, but still allows me to utilize the "smart" parts of the TV.

    The drawback is I've lost a USB port on the TV and I'm streaming wirelessly versus a wired connection. Both issues I will "get over" in short time. I do love the TV.

    Hope this helps.
  15. pmdf

    pmdf Member

    Joined:
    Jan 6, 2006
    Messages:
    19
    Trophy Points:
    3
    Ratings:
    +1
    Well, thanks to this thread I seem to have resolved it. Having read about the solutions above I thought I'd re-visit the firewall idea. I installed a third party firewall on the Mac Mini that gives me more control than the built-in Mac firewall which only enables control over incoming connections, called Doorstop X. This also gives a better view of what's attempting to access various ports so I was able to ensure I could spot and open up any ports the TV was trying to access for DLNA etc.

    Anyway, it seems that blocking access on my Mac Mini to the TV on port 5353, which I believe is used for Bonjour broadcasts, solves the issue for me. Strange too that none of the other Macs on the network are causing this problem when re-started anymore, and they don't have the firewall installed. I can only assume it's because of some media server - whether iTunes sharing or whatever - on the Mini which is sending out these Bonjour broadcasts whenever clients join or leave the network. I guess LG uses Bonjour for communicating with the remote app and the TV is confusing the broadcast as a pairing attempt.

    Fingers crossed this is a permanent solution and that the damn box doesn't start popping up again this evening! I'd be interested to know if blocking port 5353 fixes this for anyone else having the problem.
    Last edited: Jan 31, 2012
  16. noisycats

    noisycats Member

    Joined:
    Jan 17, 2012
    Messages:
    9
    Trophy Points:
    1
    Ratings:
    +0
    Awesome, that may be my solution as well. If I can get back to a wired connection and free up a USB port, then all will be perfect. Thanks.

Share This Page