Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate mail problem

Discussion in 'iPad Forum' started by jmcelroy@ntlwor, Nov 13, 2011.

  1. jmcelroy@ntlwor

    jmcelroy@ntlwor Member

    Joined:
    Apr 4, 2005
    Messages:
    162
    Trophy Points:
    18
    Ratings:
    +5
    Can anyone help me with this?

    Ever since I bought my ipad2, whenever I send a message to anyone from it, I get a copy of the message show up in my inbox on my PC.

    Now on my ipad, I have "bcc myself" set to OFF (and I've even tried switching it on, and either way I still get a copy sent to myself).

    Before I bought the ipad, I used an ipod touch, and never had this problem with that.

    I use Virginmedia as my ISP (and use POP, not IMAP) and can't find any setting there that would affect this. And also, if I sent an email from my PC, it doesn't result in a duplicate message to myself arriving on my ipad.

    I took my ipad into an Apple store the other day, but even they couldn't find a reason why this is happening either.

    It's not critical to solve this, but it is nonetheless very annoying everytime I sing into my email account on my PC to have to delete these duplicate messages.

    Does anyone have any idea why this might be happening?
  2. maf1970

    maf1970 Active Member

    Joined:
    May 2, 2006
    Messages:
    1,775
    Trophy Points:
    86
    Ratings:
    +256
  3. gkpm

    gkpm Active Member

    Joined:
    Mar 3, 2005
    Messages:
    2,528
    Trophy Points:
    106
    Ratings:
    +358
    Not completely sure, but it sounds like the iPad is using IMAP and your PC is using POP.

    What could be happening is when your iPad sends an email, it stores a copy of it on the IMAP Sent folder. Problem is POP doesn't deal with folders very well, so your PC combines inbox+sent folders and sees your sent mail as new messages.

    One solution, probably the best, could be using IMAP on the PC as well.

    The other wold be to change the Sent folder via Settings > Mail, Contacts, Calendars > [e-mail account] > Advanced > Sent Mailbox and change it so it doesn't store it on the server (note it's possible that you don't get this option)
    Last edited: Nov 13, 2011
  4. jmcelroy@ntlwor

    jmcelroy@ntlwor Member

    Joined:
    Apr 4, 2005
    Messages:
    162
    Trophy Points:
    18
    Ratings:
    +5
    Thanks for both your replies. I've just checked my iPad and it is definitely set for POP rather than IMAP. Any message sent to me appears in both my PCs and iPads inboxes, and deleting or moving it one one of them doesn't affect it on the other, which is how I want it.

    I've tried switching my PC over to IMAP, but (a) I am worried about losing my existing saved messages. I have always moved all messages, except spam, to various folders to keep - personal, mail order, business etc., and unfortunately Virgin's help section is... well, less than helpful. I also like to be able to read a message on my ipad and still be able to file it next time I am on my PC, and as I understand it, using IMAP would preclude that. Or am I wrong in thinking that?

    I've checked your suggestion, gkpm, and the options I have set up are "Delete from Server" (which is set to "never"), and Deleted Messages (set to "remove after one week"). If I were to change the "Delete from Server" option to "When removed from Inbox", would that stop me being able to then access that message on my PC, so I could file it?

    As I said, I don't have any problems with messages I receive, that part works just how I want it to. It's just messages I send from my iPad, that appear in my PCs inbox, from me.

    Am I the only reasonably computer-savvy person that finds e-mail account settings almost impossible to fathom?
  5. gkpm

    gkpm Active Member

    Joined:
    Mar 3, 2005
    Messages:
    2,528
    Trophy Points:
    106
    Ratings:
    +358
    Umm those are not the options I'm thinking about. Are you checking under "Sent Messages" (if you have something like it)

    Haven't used POP in over 5 years, it was a really basic protocol which has been hacked beyond oblivion by attempts to shoehorn more and more into it. Always gave me a poor experience.

    Not sure how easy it would be to move to IMAP for you, the main issue seems to be keeping your existing messages on the PC.

    If no one else can help I'll setup a POP server on m iPad and give it a go to see if I can figure out the problem.
  6. John7

    John7 Member

    Joined:
    Aug 6, 2004
    Messages:
    1,547
    Trophy Points:
    63
    Ratings:
    +228
    Don't know if this will help - it deals with multiple e mail clients

    Knowledge Base
  7. John7

    John7 Member

    Joined:
    Aug 6, 2004
    Messages:
    1,547
    Trophy Points:
    63
    Ratings:
    +228
    The link doent work. Heres a copy

    How do I download mail from the same account on more than one PC or mobile device, using "recent" mode?
    Access your e-mail through a Web browser
    Before you read on, did you know that you can access your Virgin Media Mail through a Web browser? This means you can send and receive messages through just about any computer with a connection to the Internet and also access other great features that are not available to users of e-mail software. Try it now: go to your Virgin Media Mail online by clicking the Email link in the top-right of the page.
    Receiving messages using multiple POP3 e-mail clients with 'recent:' mode
    If you would like to receive your e-mail using multiple POP3 e-mail clients, you will need to make a slight change to the username settings in your e-mail clients. This change will instruct the mail server to deliver all messages that have been received in your account over the last 30 days, allowing you to download the same messages on multiple e-mail clients.

    Simply add the word recent followed by a colon :)) in front of your current username. For example, if your e-mail username is richard.branson@virginmedia.com, you would need to change it to recent:richard.branson@virginmedia.com.


    If you are using a supported e-mail client, look at our configuration guides to see how to amend your e-mail username.

    Add this 'recent:' prefix to all of the e-mail clients you use in order to keep receiving messages on all of your machines.

    When you use the prefix for the first time, all messages from the last 30 days will be downloaded, which means that there may be some duplication of messages that had already been downloaded. Subsequent attempts to receive e-mail will download only new messages, so there should be no further duplication.

    Do I need to change my outgoing SMTP settings too?
    You will need to make sure that the outgoing mail authentication settings are configured to use your full e-mail address only, i.e., you should not include the 'recent:' prefix in your outgoing mail authentication settings.

    If you keep the default setting for outgoing mail authentication, i.e., using the same settings as for incoming mail, you may not be able to send mail when using 'recent:' mode. Instead, manually set the authentication details for the outgoing mail server.


    Here is an example to illustrate the correct username formats when using 'recent:' mode.


    Incoming mail (POP3) server username
    recent:richard.branson@virginmedia.com

    Outgoing mail (SMTP) server username
    richard.branson@virginmedia.com



    Do I need to change any other settings?
    Yes, you also need to set your email clients to leave a copy of the emails on the server.

    Your login details for connecting to the Internet, accessing My Virgin Media, etc. all remain unaffected.

    Are there any other ways to receive e-mail on multiple machines?
    Yes, there are a couple of other options.

    The first option is the most straightforward: you can send and receive messages through a Web browser using Virgin Media Mail online. This is the easiest way to keep all your mail in one place, and your messages will be accessible from just about any computer that has an Internet connection – easy!

    Another option is to configure your e-mail clients to use IMAP access. This is an alternative access method to POP3, and gives you direct access to your messages and folder structure on the mail server.
  8. jmcelroy@ntlwor

    jmcelroy@ntlwor Member

    Joined:
    Apr 4, 2005
    Messages:
    162
    Trophy Points:
    18
    Ratings:
    +5
    No, those setting I quoted were by going, on the iPod to "Settings", then "Mail Contacts, Calendars" then under accounts selecting "Ntlworld" (which is one of Virgin Media's" legacy email adress suffixes), then "Advanced", where you have various options. (1) Remove (set to one week, but other options are Never, After one day, After one month) (2) Use SSL (set to ON) (3) Delete from server. Currently set to "Never", but other options are "Seven Days" or "When removed from In Box" (4) S/MIME which is set to "OFF". I thought that was following your instructions.

    And on my PC, Incoming Server is "pop.ntlworld.com", Outgoing mail is "smtp:ntlworld.com", Incoming Mail server is "recent:my user name. And under advanced options Delivery "leave mail on server" is unchecked.

    I've just realised that although I use the "recent" prefix on my PC, I haven't added that on my iPad. Could that be the problem?

    When I first set up my ntlworld account, as far as I am aware POP was the only option. I don't remember ever receiving any info from Virgin about transferring over to IMAP, which is why I find the whole thing so confusing.

    And surely wanting to keep read messages in organised folders can't be that unusual, is it? As I understand it, if I were to go over to IMAP, and receive a message on my iPAD while out, with something important in it that I needed to keep, it wouldn't then show up in my PCs inbox? If I had to forward each email like that to myself each time would entail far more work than currently deleting messages I have send from my iPad each time I use my PC. Don't forget it is ONLY messages I am sending on my iPAD that appear unneccesarily in my PCs inbox.

    I am aware I can pick up my e-mail by signing into Virginmedia, but again that is far, far more trouble than just pushing my "Mail button", and anyway that wouldn't solve the actual problem I have, would it?

    I do appreciate everyone's help in trying to solve my problem.... but I'm beginning to think going back to using snail mail might be easier (grin).
  9. jmcelroy@ntlwor

    jmcelroy@ntlwor Member

    Joined:
    Apr 4, 2005
    Messages:
    162
    Trophy Points:
    18
    Ratings:
    +5
    I've just noticed something. As soon as I select the "write message" button within Mail, the field Cc/Bcc immediately has "From:my email adress" added. But in Settings, I have "Always Bcc myself" set to OFF. Is there somewhere else that this could have been set up my mistake? I checked my ipod touch, and when sending a message this field is left blank, and as I've said I don't have the problem with that, only my iPad.
  10. maf1970

    maf1970 Active Member

    Joined:
    May 2, 2006
    Messages:
    1,775
    Trophy Points:
    86
    Ratings:
    +256
    Your assumption above is incorrect. IMAP syncs what is on the client machine with what is on the server. So you have 2 copies 1 on the server one on the client machine. So in your example above if you were using IMAP and you received the email on your ipad so long as you dont move it from the inbox or delete it then it will appear on the PC also when checked.

    Recent mode fetches the last 30 days of mail, regardless of whether it's been sent to another POP1 client already.
    This suggests that it only covers mail received but I suspect it covers mail sent as well.
    What to do is take the recent part out of your settings on your PC. open mail software, receive mail then close software. Then try it on your ipad and send a test message to a friend. Then go back to the PC and see if the sent message shows up.

Share This Page