Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1080p Movies Stutter in Plex

Discussion in 'Apple Products & Services' started by snapper3166, Sep 3, 2011.

  1. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Using plex on a 2.4Ghz Core 2 Duo Mac Mini, 8Gb of RAM.

    Really like Plex now I have got used to it but when playing 1080p mkv's it starts to stutter. I know they dont have a particullay mighty GPU but surely it should be able to cope with these?

    Anyone else had the problem or is it just a setting?
  2. next010

    next010 Active Member

    Joined:
    May 29, 2005
    Messages:
    9,247
    Trophy Points:
    133
    Ratings:
    +1,795
    Do they stutter in XBMC or Boxee ?

    Is it a model with Intel GMA graphics if so then probably is the hardware. Hardware acceleration is only available with Nvidia, AMD GPU's and modern Intel-HD graphics. The GPU doesn't actually process the video it simply has a hardware decoder built into it.

    If it is the hardware then it is possible to install a Broadcom CrystalHD card into the Mini (removing the wifi card in process) and XBMC will use the CrystalHD to decode all video.
  3. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
  4. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Not sure, I havent used Boxee and I wouldnt go near XBMC again (although others seem very happy with it)

    I will check out the spec and come back.
  5. hutch

    hutch Active Member

    Joined:
    Jun 29, 2006
    Messages:
    6,222
    Trophy Points:
    136
    Ratings:
    +958
    My 2Ghz C2D 4Gb Ram Mini plays 1080p MKV's fine, I think you might find that its the latest version of Plex which is introducing "judder" to the picture as posted above. Download an earlier version and see if that sorts it.
  6. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    What size are your mkv's?
  7. hutch

    hutch Active Member

    Joined:
    Jun 29, 2006
    Messages:
    6,222
    Trophy Points:
    136
    Ratings:
    +958
    I've got ones which are 15Gb, have 25-30Gb Blu Ray rips as well. The only rip I have any slight issue with is Planet Earth which has some panning judder on certain scenes.

    What is it you are actually experiencing? Is it buffering or image judder? Have you tried an earlier version of Plex?
  8. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Not sure if it is image judder or buffeting, how do you tell?


    I will try the version you have installed if you give me the build details.
  9. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
    Hutch, i would like to download an earlier version. Where can I get an earlier one from?

    thanks
  10. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
    Found it, will reinstall and old version and hopefully this should do it
  11. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Which version did you install and where did you get it from?

    Cheers
  12. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    I had major issues with Plex last night on my Son's Winnie the Pooh movie. Worked out that I still had it on Hardware Support On and 24 frame display settings. Sound was out of sync very quickly and then stuttering. Turned Hardware Off and put on 50Hz and played perfectly.

    Then watched a 1080p movie with Hardware On and 24Hz set and played perfectly with audio in sync throughout! I think this version of Plex is more picky when it comes to the settings matching the source file. Shame there's not a simple way of getting it to change display settings dependant in the source file?

    Before you drop to an older version, trying matching the settings to the source and see if that helps?
    • Thanks Thanks x 1
  13. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Would you mind explaining exactly wat that means and how to do it in Plex. I'm new to it.
    • Thanks Thanks x 1
  14. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    You do it in the System Prefs of OS X rather than in Plex, unfortunately as it's a pain this way. I don't know a quicker route unless someone else can advise?

    Click on the Apple logo on top left of your desktop, then System Prefs, then go to displays and set it there.
    • Thanks Thanks x 1
  15. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    OK I have set it to 50Hz which is what the mkv is, where is Hardware Support? I can not see it. Is that a Plex setting?

    I am running Snow Leopard and Display was under Appl Logo > Hardware > Display.

    Hope that helps
  16. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    Hardware Support is in the Plex Settings Video page. Depending on the skin you use it shows in different places.

    Snow Leopard still has the Display Option in System Prefs also, on top of where you found it.
  17. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Standard Skin

    Is it called "H.264 Hardware Decoding" ?
  18. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    If it is I have turned it off..... same result, stuttering sound and video....
  19. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    You have the correct setting and strange it's not working now. Are you sure your original 1080p movie is 50Hz?

    Is it PAL or NTSC? Is it from BluRay originally?
  20. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
  21. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
    bpsmith- legend!!! It's now working!!! After over a month of grief it's finally working!! Thank you so much!!

    Ps i didn't download any previous versions.
    Last edited: Sep 5, 2011
  22. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Yep, ripped straight from BluRay, 12Gb File, 50hz.......

    Is there a way to double check i.e. a peice of mac software that will analyze it and tell me exact details
  23. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    Which element fixed it for you fella?
  24. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    All of the BluRay movies I have seen are in 24 frame mode or 23.96Hz to be precise. Therefore you should be using 24Hz setting on 1080p.
  25. shahedz

    shahedz Active Member

    Joined:
    Apr 26, 2005
    Messages:
    9,786
    Trophy Points:
    136
    Ratings:
    +963
    Changed the display setting to 50hz and turned off the hardware encoding.

    thanks again!
  26. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    No worries. I have been there and know exactly how it feels!
  27. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    OK, sorry for the delay work has been crazy.

    Done some more testing:

    Plex 9 does it always whatever the display resolution is set to (shows DTS on the receiver), tried files on network and locally so its not a network problem.
    Plex 8 does the same (Shows DTS on the receiver)
    VLC plays it fine.... but shows Stereo on the receiver.

    Windows plays the file fine as does my sony DVD when it is streamed DLNA to it.

    Any further ideas?
  28. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    Update on this if anyone is still watching.

    i have now discovered it is aproblem only with DTS files, DD and stereo are fine.

    Can anyone test this on theirs and let me know if its ageneric Plex problem....
    Cheers
  29. bpsmith

    bpsmith Active Member

    Joined:
    Jan 8, 2010
    Messages:
    7,573
    Trophy Points:
    133
    Ratings:
    +709
    I suspect their actually DTS-HD files that play as down mixed DTS in Plex as doesn't support HD-Audio. They used to stutter on the old version of Plex with me until I stripped them back to just DTS. Not sure if this is the same on 9.5, as I only use DTS these days since finding out.

    Can confirm that all my normal DTS stuff plays perfectly though.
  30. snapper3166

    snapper3166 Member

    Joined:
    Aug 22, 2005
    Messages:
    1,196
    Trophy Points:
    51
    Ratings:
    +67
    How can I check what they are trancoded with, either on th emac or the PC.

    Not sure I am on 9.5 yet, will have to check version later

Share This Page